No announcement yet.

U3 Sucks (but I Rock)

  • Filter
  • Time
  • Show
Clear All
new posts

  • U3 Sucks (but I Rock)

    One of my students was really looking forward to purchasing her first jump-drive. When she finally picked one up, it did odd things when plugged into her iBook. MacOS X informed her that she'd inserted a blank CD. The "working" light blinked intermittently and apparently at random. The drive still worked, but the student was really disappointed that it was doing these weird things, and I couldn't blame her.

    One of my joys is in watching my students embrace certain technologies, and then make them part of their lifestyles. People who love their computers are more likely to use them. When students begin to understand how meaningful a tool (and how understanding a friend!) a computer can be, they grow into better students. A personal computer is a college student's second-best friend, right behind a good writing tutor.

    Oh, and the pizza-delivery guy.

    So it really bummed me out that this student wasn't getting what she wanted out of this drive. She asked me to take a look at it.

    This was a sleek, sexy number: a Sandisk Cruzer Micro 512. It's about the size of two pieces of Eclipse gum laid end to end, and has a neat little green light at the end. I stuck it into my iBook and saw what she meant. I could see, too, how much of an irritation this was. When I looked at the info on the drive, it showed only an available 400+ megs of storage, which seemed low, so I thought I'd erase the thing and rename it. I ran MacOS's resident disk utility program, and AHA. This thing was showing up partitioned. I don't know enough about storage to understand what was really happening, but according to the utility, the drive showed at least three directory levels, with the second level the one showing up in the finder sidebar, as if the uppermost level wasn't even there. I erased the subdirectories (with exactly the same effect -- renaming one renamed the other) and tried to erase the parent directory, but it showed up as read-only.

    And the available storage was unchanged.

    I thought I'd try reformatting the drive on a PC, since a lot of these things are preformatted for PCs. As soon as I stuck the drive in, I could see what the problem was. The flash drive launched an application automatically, something called the U3 Launchpad. I couldn't tell what it was, but I knew I didn't like it. So I did a format, but got the message that the machine couldn't complete the format!

    At least I knew what to Google. It turns out that some USBs are coming pre-installed with the U3 Launchpad, which emulates the Windows START menu (thanks to our friends at Wikipedia). It lets you carry application software with you and run it on any computer you happen to use. The reason I couldn't see what it was doing when I stuck it into my iBook was that (of course) it doesn't work with MacOS. Erasing whatever files you can does no good, because the Launchpad is built into the flash memory and is designed to reload itself.

    Who the heck thought this was something we wanted? I mean, making apps portable, that's a cool thing. But selling hardware with software that won't uninstall? That reeks of the kind of arrogance that just pisses me off.

    A little more research, and I discover that the guys at Geek Squad wrote a little app (also an .exe file) that gets rid of all of that U3 crap, and someone has posted it. I won't provide a link, because I don't think its being out there is authorized, but you won't have any problem tracking down a quick download if you Google "remove U3." Or send me a private message and I'll hook you up.

    Once I got what I wanted, reformatting the flash drive was a matter of about fifteen seconds. The drive works like the beauty it is, now, and I am eager to see my student's face when she sees that COMPUTER MAN DOES IT AGAIN.

    Yeah, yeah. I know what I did wasn't that big a deal. I'm posting this mostly because I really want anyone who experiences this problem to be able to find help. The more available this fix is, the better. Screw those U3 guys. At least until they package their crap with its own uninstaller.
    But I'm disturbed! I'm depressed! I'm inadequate! I GOT IT ALL! (George Costanza)

  • #2
    Re: U3 Sucks (but I Rock)

    I believe google is partnering up with a bunch of other companies to offer something similar (a bunch of apps preloaded onto a thumb drive - like googlepack).

    I believe I saw the U3 app in a computer magazine once (or was it online). I'll keep a look out for that kind of thumb drive when I go shopping for a new one soon (suddenly, 512mb is getting too small, and my Creative MicroPhoto's 2gb capacity is also shrinking)
    How'd I get so white and nerdy?


    • #3
      Re: U3 Sucks (but I Rock)

      The key loop on my Sandisk Cruzer Micro 1GB snapped off, so I decided it was time to upgrade. I picked up the Sandisk Cruzer Titanium 2GB at Costco. A bit bigger, but I like the (hopefully) more sturdy key loop and the retracting USB plug.

      Of course, it had that awful U3 stuff on it. 40MB of protected data for a Windows "utility" I didn't want, nor could use on my Mac.

      Fortunately, Sandisk now provides a standalone U3 Launchpad Removal Tool. I guess all those homemade hacks were starting to turn into a support nightmare for them. So I downloaded it, ran it, and ten seconds later:

      "The Launchpad program was removed successfully. The USB drive is now a storage only device."

      The biggest hassle? I had to fire up my Windows machine to do this. 'Twas the first time I turned it on since June sometime, and there were 16 security updates to apply!


      • #4
        Re: U3 Sucks (but I Rock)

        Forgive the interruption, as I know nothing much about computers, but I must thank you for the smile and the blast to the past ,
        I know what a Scivener is.
        I was called that at one time
        Thanks again


        • #5
          Re: U3 Sucks (but I Rock)

          I have a Sandisk Cruzer Micro USB flash drive in the store right now, and I'm tempted to get it for $80 (a few bucks cheaper than compUSSR), but I heard that the software that comes with it sucks. How has the U3 software been treating you users who has it?
          How'd I get so white and nerdy?


          • #6
            Re: U3 Sucks (but I Rock)

            Originally posted by doc1456 View Post
            I have a Sandisk Cruzer Micro USB flash drive in the store right now, and I'm tempted to get it for $80 (a few bucks cheaper than compUSSR), but I heard that the software that comes with it sucks. How has the U3 software been treating you users who has it?
            I've read nothing but complaints about U3, and the fact that Sandisk had to make available an official removal tool demonstrates its unpopularity. If I want my thumb drive to do some fancy tricks, I'll install and configure it myself. A flash drive that tries to behave like anything else is annoying, and most likely a problem just waiting to happen.

            I moved from the Cruzer Micro to the Cruzer Titanium. I miss the Micro's size, but the Titanium's "sturdy" factor counts for a lot. It's a bit wide (so it may not fit in some side-by-side USB slots), but I like that it's metal-ish rather than rubber-coated-plastic, and again, I love that the USB plug retracts rather than requiring a @$^@ cap. Having been through at least half a dozen thumb drives, I can't tell you how many covers I've misplaced.


            • #7
              Re: U3 Sucks (but I Rock)

              If it's any consolation, SanDisk's stock got hammered last week
              website -
              blog -